Začínáme

Základní instrukce

  1. Prověřte, zda splňujete minimální nároky FW
  2. Stáhněte si kopii FW
  3. Nahrajte ji do šablony
  4. Vytvořte strukturu vlastního projektu
  5. Začněte s vývojem!

1. Minimální nároky

Framework potřebuje pouze minimum systémových nároků, které je potřeba dodržet pro jeho čistý běh.

  • PHP 5.6 nebo vyšší (minimálně však 5.4)
  • WordPress 4.3 nebo vyšší (minimálně však 4.0)

2. Základní instalace

Staženou složku KT nahrajte do Vaší root složky se šablonou – například:
wp-content/moje-sablona/kt/, následně otevřete soubor functions.php a zapište do něj následující kód:

Ve složce KT si vytvořte vlastní složku, kterou můžete nazvat nejlépe – yours. V ní vytvořte soubor kt_init.inc.php, do kterého zapište:

Hotovo! Právě Vám v šabloně běží KT WP Framework! Nebylo to tak složité, že?

Ve vámi definované složce – yours – musí být následně složka requires. V této složce se bude vše automaticky includovat, pokud budou splněny všechny podmínky.

Pro snadnější začátek jsme připravili kostru projektu, kde jsou připraveny základní modely, configy atd…
Stačí stáhnout nejnovější vydání z GitHubu a řídit se výše zmíněnými a přiloženými README pokyny.

Dále pokračujte:

  • pro další informace do dokumentace,
  • přímo ke stažení v download,
  • na před připravený Skeleton pro snadnější tvorbu vlastních šablon,
  • nebo třeba k prohlédnutí na GitHub (náš profil),
  • anebo si přečtěte licenci


Odebírejte novinky z FW

Sledujte nás!

Tyto stránky využívají Cookies. Používáním těchto stránek vyjadřujete souhlas s používáním Cookies.Zjistit víceOK, rozumím